Помощь ◄Помощь► Magento

Статус
В этой теме нельзя размещать новые ответы.

Violent

V-Power! (7 Years with Nulled! <3)
Регистрация
17 Окт 2012
Сообщения
375
Реакции
296
Тему создано специально для помощи в настройке, установке и другого, что связано с CMS Magento.

Прежде чем написать в этой или любой-другой теме, ОБЯЗАТЕЛЬНО прочите правила раздела: Для просмотра ссылки Войди или Зарегистрируйся (незнание правил, не освобождает от ответственности и наказания!)

Если вопрос не касается настройки Magento, то тогда вам нужно заглянуть в одну из этих тем:

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся​

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Свою проблему описывайте как можно подробней и по возможности обязательно нужно давать примеры страниц (код, скриншоты или ссылки на сайт под спойлер или хайд)!

И еще! Если вопрос тупой или настолько очевиден что на него уже неоднократно давали ответ как здесь так и в интернете, то он моментально удаляется, а пользователь после повторного похожего вопроса моментально улетает в БАН! Потому, пользуйтесь поиском как здесь на форуме, так и в интернете.

P.S.
Если проблема не решается в 3-4 сообщения, это не проблема, это кривые руки!
:att:
P.P.S. Прежде чем задать вопрос обновите кэш, индексы и отключите компиляцию, а лучше при настройке/доработке отключите всё что только можно! Иначе, тупые вопросы попросту будут удаляться.

__________________________________________________________________________________________________________________________________
Начну.. Есть бесплатный модуль Для просмотра ссылки Войди или Зарегистрируйся, спокойно становится на версию 1.7, но ошибка появляется при переходе на сайт liqpay:
"Ошибка! Не передана информация для покупки.error:
Сумма должна быть больше 0.02 грн
Валюта не присутствует...."
.
Нужно решить эту проблему, кто возьмется за ее решения (можно не бесплатно, тогда писать в личку)?
P.S. На самом Для просмотра ссылки Войди или Зарегистрируйсяесть "некий" совет как это решить, но для меня он не понятен.

P.P.S. Проблема решена, кому надо обращайтесь.
 
Последнее редактирование:

Violent

V-Power! (7 Years with Nulled! <3)
Регистрация
17 Окт 2012
Сообщения
375
Реакции
296
Тему создано специально для помощи в настройке, установке и другого, что связано с CMS Magento.

Прежде чем написать в этой или любой-другой теме, ОБЯЗАТЕЛЬНО прочите правила раздела: Для просмотра ссылки Войди или Зарегистрируйся (незнание правил, не освобождает от ответственности и наказания!)

Если вопрос не касается настройки Magento, то тогда вам нужно заглянуть в одну из этих тем:

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся​

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Для просмотра ссылки Войди или Зарегистрируйся

Свою проблему описывайте как можно подробней и по возможности обязательно нужно давать примеры страниц (код, скриншоты или ссылки на сайт под спойлер или хайд)!

И еще! Если вопрос тупой или настолько очевиден что на него уже неоднократно давали ответ как здесь так и в интернете, то он моментально удаляется, а пользователь после повторного похожего вопроса моментально улетает в БАН! Потому, пользуйтесь поиском как здесь на форуме, так и в интернете.

P.S.
Если проблема не решается в 3-4 сообщения, это не проблема, это кривые руки!
:att:
P.P.S. Прежде чем задать вопрос обновите кэш, индексы и отключите компиляцию, а лучше при настройке/доработке отключите всё что только можно! Иначе, тупые вопросы попросту будут удаляться.

__________________________________________________________________________________________________________________________________
Начну.. Есть бесплатный модуль Для просмотра ссылки Войди или Зарегистрируйся, спокойно становится на версию 1.7, но ошибка появляется при переходе на сайт liqpay:
"Ошибка! Не передана информация для покупки.error:
Сумма должна быть больше 0.02 грн
Валюта не присутствует...."
.
Нужно решить эту проблему, кто возьмется за ее решения (можно не бесплатно, тогда писать в личку)?
P.S. На самом Для просмотра ссылки Войди или Зарегистрируйсяесть "некий" совет как это решить, но для меня он не понятен.

P.P.S. Проблема решена, кому надо обращайтесь.
 
Последнее редактирование:
Есть проблема, сайт работает нормально, все вроде бы и хорошо, но 1 раз в день выскакивает вот такая ошибка(см. скриншот), которая решается только перезагрузкой сервера.
Каждый день перезагружать сервер по 2 раза нет сил уследить, как можно решить проблему? в гугле видел решение: Для просмотра ссылки Войди или Зарегистрируйся , но что-то не помогло.
Могло ли повлиять, что хост mysql в свое время изменили с 127.0.0.1 на localhost (вроде одно и тоже, но где-то слыхал что разница в данном случае есть)? Есть кто понимающий в администрировании серверов?

service mysql restart не помогает? Зачем целиком сервер перезагружать? Вообще, это похоже на то, что мускул не тот сокет видит.
Мускул через ssh в этот момент вообще не видит, проблему нужно как-то решать, все равно, какая разница, где перегружать, на серве 1 сайт.
 

Вложения

  • socket.png
    socket.png
    199,7 KB · Просмотры: 10
Последнее редактирование модератором:
Есть проблема, сайт работает нормально, все вроде бы и хорошо, но 1 раз в день выскакивает вот такая ошибка(см. скриншот), которая решается только перезагрузкой сервера.
Каждый день перезагружать сервер по 2 раза нет сил уследить, как можно решить проблему? в гугле видел решение: Для просмотра ссылки Войди или Зарегистрируйся , но что-то не помогло.
Могло ли повлиять, что хост mysql в свое время изменили с 127.0.0.1 на localhost (вроде одно и тоже, но где-то слыхал что разница в данном случае есть)? Есть кто понимающий в администрировании серверов?
service mysql restart не помогает? Зачем целиком сервер перезагружать? Вообще, это похоже на то, что мускул не тот сокет видит.

Мускул через ssh в этот момент вообще не видит, проблему нужно как-то решать, все равно, какая разница, где перегружать, на серве 1 сайт.

У вас MySQL сервер на этой же машине? Тогда зачем до него SSH пробрасывать?

Вообще, это похоже на проблемы с сокетом MySQL, должно помочь изменение localhost обратно на 127.0.0.1, чтобы залатать дыру на скорую руку.
 
Последнее редактирование модератором:
Могло ли повлиять, что хост mysql в свое время изменили с 127.0.0.1 на localhost (вроде одно и тоже, но где-то слыхал что разница в данном случае есть)? Есть кто понимающий в администрировании серверов?
Разницы особо нету
у вас же сокет в My.cnf
в любом случае явно прописан
типа
port = 3306
socket = /var/lib/mysql/mysql.sock

ваша ошибка говорит о том что тупо сам мускуль отвалился. Сервер ОБЫЧНО завершает процесс мускуль если там с памятью проблема.
тогда реально нужно или принудительно стартовать процесс мускуля ( вручную или проверять по крону жив ли процесс мускуль и если не жив то запускать через sh скрипт )
Но это костыли и извращения

Более грамотный вариант всеже посмотреть логи, из за чего отвалился. Притюнить конфиги ну и тариф на крайняк повысить.
без логов - тут гадание на кофейной гуще.
 
Разницы особо нету
у вас же сокет в My.cnf
в любом случае явно прописан
типа
port = 3306
socket = /var/lib/mysql/mysql.sock

ваша ошибка говорит о том что тупо сам мускуль отвалился. Сервер ОБЫЧНО завершает процесс мускуль если там с памятью проблема.
тогда реально нужно или принудительно стартовать процесс мускуля ( вручную или проверять по крону жив ли процесс мускуль и если не жив то запускать через sh скрипт )
Но это костыли и извращения

Более грамотный вариант всеже посмотреть логи, из за чего отвалился. Притюнить конфиги ну и тариф на крайняк повысить.
без логов - тут гадание на кофейной гуще.

Вот это файлы логов?

Скрытое содержимое доступно для зарегистрированных пользователей!


нет:)
логи обычно лежат в
var/log
причина отвала может быть в
var/log/syslog.log
либо
var/log/mysql/mysql.log

я смотрю у вас ispmanager - посмотрите еще нагрузку там в дашбоард, либо по SSH командой top или htop

НО...
если вы не знаете где лежат логи, то тем более не сможете сами их прочитать и предпринять какие либо верные действия.

Буду признателен, если кто-то что сможет сказать..... :conf:

Ну вот как я и ванговал: не хватило ему памяти и он ушел в шотдаун.

160113 15:58:19 InnoDB: Completed initialization of buffer pool
160113 15:58:19 InnoDB: Fatal error: cannot allocate memory for the buffer pool
160113 15:58:19 [ERROR] Plugin 'InnoDB' init function returned error.
160113 15:58:19 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
160113 15:58:20 [ERROR] mysqld: Out of memory (Needed 128917504 bytes)
160113 15:58:20 [Note] Plugin 'FEEDBACK' is disabled.
160113 15:58:20 [ERROR] Unknown/unsupported storage engine: InnoDB
160113 15:58:20 [ERROR] Aborting

160113 15:58:20 [Note] /usr/libexec/mysqld: Shutdown complete
Большое спасибо за расшифровку!

Но как понимать, что он работает норм после перезагрузки и только через время происходит в такое?
Это может быть результат DDos'a?

39d4af60ffbc417bbb2227e2c45aeb40.png
 

Вложения

  • mariadb.txt
    403 KB · Просмотры: 4
Последнее редактирование модератором:
Вот это файлы логов?
нет:)
логи обычно лежат в
var/log
причина отвала может быть в
var/log/syslog.log
либо
var/log/mysql/mysql.log

я смотрю у вас ispmanager - посмотрите еще нагрузку там в дашбоард, либо по SSH командой top или htop

НО...
если вы не знаете где лежат логи, то тем более не сможете сами их прочитать и предпринять какие либо верные действия.

Буду признателен, если кто-то что сможет сказать..... :conf:

Ну вот как я и ванговал: не хватило ему памяти и он ушел в шотдаун.

160113 15:58:19 InnoDB: Completed initialization of buffer pool
160113 15:58:19 InnoDB: Fatal error: cannot allocate memory for the buffer pool
160113 15:58:19 [ERROR] Plugin 'InnoDB' init function returned error.
160113 15:58:19 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
160113 15:58:20 [ERROR] mysqld: Out of memory (Needed 128917504 bytes)
160113 15:58:20 [Note] Plugin 'FEEDBACK' is disabled.
160113 15:58:20 [ERROR] Unknown/unsupported storage engine: InnoDB
160113 15:58:20 [ERROR] Aborting

160113 15:58:20 [Note] /usr/libexec/mysqld: Shutdown complete

Большое спасибо за расшифровку!
Но как понимать, что он работает норм после перезагрузки и только через время происходит в такое?
Это может быть результат DDos'a?
Смотрите Access.log - там видно ддос это или не ддос
 
Последнее редактирование модератором:
если бы это был ddos - то у вас бы сайт валился практически сразу, а не пару раз в сутки.
это результат неверно настроенного мускуля.
Дело может быть в том, что изменили хост с 127.0.0.1 на localhost?
 
MageLynx Import/Export plugin

альтернатива родному на базе magmi

Для просмотра ссылки Войди или Зарегистрируйся

Очень быстрый экспорт, по сравнению с 1_8_x_bulk_custom_import_products_v37_magento_1_7_x-1_9_x, который тут выкладывали, быстрее в десятки раз. Так же тестировал и другие импорты/экспорты, этот оказался самым быстрым.

Единственное, с чем не могу разобратся, почему MageLynx не выгружает media_gallery?

Сразу подумал что модуль не рабочий, потом методом тыка определил, если в настройках указать что нужно выгружать media_gallery, то выгрузка не происходит. Если не указывать, то работает.

Кто сталкивался с подобным ?
 
Всем привет! Подскажите, может кто сталкивался. после переиндексации цен - не отображаются товары в категориях, хотя в админке все ок
А FPC есть? не Амасти случаем?
 
Всем привет! Подскажите, может кто сталкивался. после переиндексации цен - не отображаются товары в категориях, хотя в админке все ок
не могу сказать , что связанно с периндексацией, но подобные проблемы были,
проверьте наличие товара (кол-во товара, которое не отображается и посмотрите курс валют на всяк случай, может звучит глупо, но если слетает курс валюты товар не выводится)
 
Последнее редактирование:
Статус
В этой теме нельзя размещать новые ответы.
Назад
Сверху